Discussion:
i3status - remaining battery time not shown
(too old to reply)
Hendrik Lüth
2018-09-30 21:35:47 UTC
Permalink
Hello fellow i3-Users,

I have problem with i3status and the remaining battery lifetime.
When I charge my Laptop, i3status correctly displays the remaining time
until the battery is fully charged (%remaining). If I run on battery there
is nothing displayed, as if the config-option wasn't there. If I run the
command "upower -i /org/freedesktop/UPower/devices/battery_BAT0", I get the
correct (but rounded) output for "time to empty". I have tried using the
"path"-option in i3status to make it display the value correctly, but it
didn't help either.

As it looks like that there is a way to display this value, I'd like to
request your help on this, as I want to find out, wether it's a bug in i3.

The Laptop is an HP ZBook 15 Gen 4, running i3 version 4.15 (2018-03-10)
and and Arch Linux with Kernel 4.18.10.

Kind Regards,
Hendrik
Jeff Abrahamson
2018-10-01 05:28:57 UTC
Permalink
Post by Hendrik Lüth
Hello fellow i3-Users,
I have problem with i3status and the remaining battery lifetime.
When I charge my Laptop, i3status correctly displays the remaining
time until the battery is fully charged (%remaining). If I run on
battery there is nothing displayed, as if the config-option wasn't
there. If I run the command "upower -i
/org/freedesktop/UPower/devices/battery_BAT0", I get the correct (but
rounded) output for "time to empty". I have tried using the
"path"-option in i3status to make it display the value correctly, but
it didn't help either.
Hi, Hendrik.

What does your i3status specify for the battery?

In case a working example might help, mine looks like this
<https://github.com/JeffAbrahamson/dotfiles/blob/master/i3/i3/i3status.conf#L40>. 
I also use this script
<https://github.com/JeffAbrahamson/dotfiles/blob/master/i3/i3/bin/i3-power-status>. 
(On my host, their outputs agree.)
--
Jeff Abrahamson
+33 6 24 40 01 57
+44 7920 594 255

http://p27.eu/jeff/
http://transport-nantes.com/
Loading...